Data Loading Issue on the Publisher Portal
Major incident
Websites
Publisher Portal
2026-02-09 18:33 UTC
· 1 hour, 48 minutes
Updates
Resolved
February 9, 2026 · 20:22 UTC
The underlying issue has been identified and resolved, and the website is fully operational.
Monitoring
February 9, 2026 · 19:38 UTC
The issue has been resolved. We are actively monitoring the system to ensure stability.
Issue
February 9, 2026 · 18:33 UTC
Publisher data cannot be loaded at this time. The team is actively investigating the root cause. We will provide updates as soon as more information is available.
← Back
Services Status