Delay in Ad Revenue APIs (Impression & User-Level)
Minor incident
Grow Ads
Levelplay
Ad revenue measurement API
2026-02-19 10:01 UTC
· 2 days, 37 minutes
Updates
Resolved
February 21, 2026 · 10:36 UTC
The data in the Impression-Level and User-Level Ad Revenue APIs, which was delayed on February 18th and February 19th is available. The issue has been resolved and data delivery has returned to normal.
Investigating
February 20, 2026 · 14:54 UTC
The delay in the Impression-Level and User-Level Ad Revenue APIs is still ongoing and is impacting data for February 18th and February 19th. We’re continuing to work on restoring data availability and will share another update as soon as we have it.
Issue
February 19, 2026 · 10:01 UTC
Yesterday’s data in the Impression-Level and User-Level Ad Revenue APIs is currently delayed. We expect the data to be available within a few hours and will provide an update once it is being processed.
← Back
Services Status