Investigating: UVCS Free Trial Signup/Activation Issue

Minor incident Collaboration / Unity DevOps Unity Version Control Web
2026-03-07 00:00 UTC · 8 hours, 23 minutes

Updates

Resolved

Issue is solved. Free trial is working normally.

March 7, 2026 · 08:23 UTC
Issue

New organizations are currently unable to start the UVCS free trial. Existing customers are not impacted. We are actively investigating and will provide updates as we learn more.

March 7, 2026 · 00:00 UTC

← Back