Issue spinning up new machines - Multiplay Game Server Hosting
Minor incident
Multiplayer
Multiplay
Multiplay API
Multiplay Datacentres
Game Server Hosting (UDash)
Clanforge
2026-03-11 09:35 UTC
· 2 hours, 36 minutes
Updates
Resolved
March 11, 2026 · 11:32 UTC
We are seeing full recovery on the service and customers should now be able to spin up new machines without issue.
Investigating
March 11, 2026 · 10:40 UTC
Our engineering team have applied a fix and we are seeing recovery for a subset of users.
Our team continues to work on this issue - we will provide a further update when progress has been made towards complete recovery.
Investigating
March 11, 2026 · 09:35 UTC
We are aware of an issue affecting some customers and their ability to spin up new game servers via the Multiplay service. Our engineering team have identified the root cause of the issue and are working on a fix.
← Back
Services Status