Multiplay and Matchmaker Outage - Major Service Impact
Major incident
Multiplayer
Multiplay
Multiplay API
Multiplay Datacentres
Game Server Hosting (UDash)
Clanforge
Statistics
Matchmaker
2026-03-17 12:00 UTC
· 1 hour, 11 minutes
Updates
Resolved
March 17, 2026 · 13:10 UTC
We are now seeing full recovery of the Multiplay and Matchmaker services, as such this incident is being resolved.
Monitoring
March 17, 2026 · 12:57 UTC
Our engineering team identified the root cause of the outage and have applied a fix. We are seeing new allocations enter the system successfully.
We continue to monitor closely and this incident will remain open until the service is fully restored.
Investigating
March 17, 2026 · 12:29 UTC
We are aware of and are in the process of investigating an issue affecting the Multiplay Game Server Hosting and Matchmaker services. The issues is affecting new allocations to the service, as well as the QoS services that support Multiplay and Matchmaker.
We will update this post as and when we have made progress in restoring service.
← Back
Services Status