Multiplay and Matchmaker Service Degradation

Major incident Multiplayer Multiplay Multiplay API Multiplay Datacentres Game Server Hosting (UDash) Clanforge Statistics Matchmaker
2026-03-17 13:35 UTC · 7 hours, 13 minutes

Updates

Resolved

We’ve seen a full recovery of the Multiplay and Matchmaker services and consider this incident resolved.

March 17, 2026 · 20:45 UTC
Monitoring

We’ve confirmed stability for the Multiplay Game Server Hosting and Matchmaker services. We will continue to monitor our services.

March 17, 2026 · 17:08 UTC
Investigating

We have seen a recovery to stability for the Multiplay Game Server Hosting and Matchmaker services.
We will continue to monitor our services and investigate the underlying issue.

March 17, 2026 · 16:23 UTC
Investigating

While we are seeing periods of recovery, we are encountering issues with our recovery process which is leading to service interruption and instability.

Our Engineering team continues to investigate and are working to alleviate the issue affecting our recovery process.

March 17, 2026 · 14:55 UTC
Investigating

We are aware of and are in the process of investigating an issue affecting the Multiplay Game Server Hosting and Matchmaker services. The issues is affecting new allocations to the service, as well as the QoS services that support Multiplay and Matchmaker.

We will update this post as and when we have made progress in restoring service.

Note that this is a secondary incident to one that was posted earlier in the day.

March 17, 2026 · 13:43 UTC

← Back