AssetStore increased latency

Minor incident Websites Asset Store
2026-03-19 09:27 UTC · 4 hours, 22 minutes

Updates

Resolved

We’re still continuing to monitor

March 19, 2026 · 13:50 UTC
Monitoring

The latency increase has subsided and we will continue to monitor the AssetStore’s performance.

March 19, 2026 · 10:41 UTC
Investigating

We are investigating reports of increased latency on the Asset Store. Users may experience slower page load times and intermittent issues when submitting asset reviews. Our team is working to identify the root cause.

March 19, 2026 · 09:27 UTC

← Back