Authentication Incident Server Error 500

Minor incident LiveOps Leaderboards Unity Authentication
2026-03-20 02:30 UTC · 11 hours, 51 minutes

Updates

Resolved

The incident is now resolved.

March 20, 2026 · 14:21 UTC
Monitoring

Service has been restored. After resetting affected services, we have confirmed that player name retrieval is functioning normally. We are now in a monitoring phase to ensure a full recovery.

March 20, 2026 · 04:21 UTC
De-escalate

The authentication service is working, but retrieving and updating PlayerNames is not. This will affect Friends and Leaderboards.

We continue our investigation and will report back with our findings.

March 20, 2026 · 02:55 UTC
Issue

We have received multiple reports regarding certain players hitting server error 500. The error is affecting player login and the display of player names on Leaderboards.

We are currently investigating this issue and will report back shortly.

March 20, 2026 · 02:30 UTC

← Back