Friends down due to Playernames outage.
Major incident
Multiplayer
Friends
2026-03-20 03:23 UTC
· 10 hours, 57 minutes
Updates
Monitoring
March 20, 2026 · 04:31 UTC
Service has been restored. After resetting affected services, we have confirmed that player name retrieval is functioning normally. We are now in a monitoring phase to ensure a full recovery.
Investigating
March 20, 2026 · 03:23 UTC
We are investigating a technical issue with the Friends service affecting the retrieval of player names. Thank you for your patience while we work on a fix.
← Back
Services Status