Cost & Usage dashboard reporting inaccuracies for Unity DevOps

Minor incident Collaboration / Unity DevOps Unity Build Automation Cost & Usage Reporting Unity Pipeline Automation Cost & Usage Reporting Unity Version Control Cost & Usage Reporting
2026-04-27 14:00 UTC · 2 days, 20 hours, 29 minutes

Updates

Investigating

We are currently investigating an issue affecting Seats and Concurrency usage reporting for March, and April 2026. As a result, usage values may be displayed inaccurately in the dashboard.

Please note that March invoices remain accurate. April invoices will be corrected before charges are finalized.

April 28, 2026 · 14:04 UTC
Resolved

Usage values are back to normal. The march invoices were calculated with accurate information, guaranteeing that there were no overcharges.

The reporting charts are also showing accurate information, which reflect the actual storage usage of your DevOps subscriptions.

April 24, 2026 · 18:27 UTC

← Back