[Build Automation] Project Statistics & Build Target Errors

Major incident Collaboration / Unity DevOps Unity Build Automation Backend Service Queue Performance - Mac Builders Queue Performance - Windows Builders License Activations - Unity Editor Cost & Usage Reporting
2026-05-08 10:02 UTC · 4 hours, 25 minutes

Updates

Resolved

The incident has been resolved. Apologies for the inconvenience.

May 8, 2026 · 14:26 UTC
Monitoring

We have identified an issue that we believe is responsible for the Project Statistics & Build Target errors on the Build Automation service. A fix has been deployed, and pages previously displaying errors are functioning as expected again.

Our engineering team is actively monitoring the service, and will post further updates.

May 8, 2026 · 12:28 UTC
Investigating

We are currently investigating an issue. Our engineering team is actively triaging the situation, and we will provide an update as soon as we have more information.

May 8, 2026 · 10:19 UTC

← Back