Order fulfillment outage on Commerce platform
Major incident
Websites
Unity Dashboard
Unity Store
2026-05-09 08:37 UTC
· 2 days, 8 hours, 9 minutes
Updates
Resolved
May 11, 2026 · 16:46 UTC
The incident has been resolved and we are monitoring the situation.
Issue
May 11, 2026 · 09:37 UTC
We are currently investigating issues related to orders not being fulfilled that customers are placing for purchases and cancellation as one of partner systems is down. Our engineering team is actively triaging the situation, and we will provide an update as soon as we have more information.
← Back
Services Status