Elevated latencies and error responses with the leaderboard service
Minor incident
LiveOps
Leaderboards
2026-05-13 18:00 UTC
· 1 hour, 12 minutes
Updates
Resolved
May 13, 2026 · 19:12 UTC
The incident has been resolved and we are monitoring the situation.
Resolved
May 13, 2026 · 19:12 UTC
The incident has been resolved and we are monitoring the situation.
Issue
May 13, 2026 · 18:34 UTC
We are currently investigating an issue. Our engineering team is actively triaging the situation, and we will provide an update as soon as we have more information.
← Back
Services Status