Build Automation – Degraded Performance (Europe Region)

Major incident Collaboration / Unity DevOps Unity Build Automation Queue Performance - Mac Builders
2026-05-14 15:42 UTC · 4 hours, 36 minutes

Updates

Resolved

This issue has been resolved. Build Automation Mac builds in the Europe region are now fully operational. Thank you for your patience.

May 14, 2026 · 20:17 UTC
Investigating

We are currently experiencing degraded performance affecting UBA Mac builds in the Europe region. Our team is actively investigating and working to restore service.

May 14, 2026 · 15:42 UTC

← Back