Partial outage - Relay
Minor incident
Multiplayer
Relay
2026-05-20 23:15 UTC
· 1 hour, 28 minutes
Updates
Resolved
May 21, 2026 · 00:43 UTC
The incident has been resolved and we are monitoring the situation.
Investigating
May 21, 2026 · 00:15 UTC
We are currently investigating an issue with Relay. Our engineering team is actively triaging the situation, you may see issues allocating in some regions; southamerica-east.
← Back
Services Status