Degraded leaderboard performance
Minor incident
LiveOps
Leaderboards
2026-06-17 13:53 UTC
· 2 hours, 59 minutes
Updates
Resolved
June 17, 2026 · 16:52 UTC
We’ve identified the cause and applied mitigations, and are continuing to watch Leaderboard responses to ensure it resolves things
Issue
June 17, 2026 · 14:23 UTC
We’ve identified an issue causing Leaderboards to run slower than usual, which may impact load times for end users.
← Back
Services Status