Investigating latency with Cloud Save writes.

Major incident LiveOps Cloud Save
2026-07-07 12:26 UTC · 6 hours, 18 minutes

Updates

Resolved

After monitoring yesterday, we confirmed this issue is resolved

July 8, 2026 · 11:06 UTC
Monitoring

The service is now in a stable state. We continue monitoring the services and will remove the incident status as soon as we can confirm everything is in a healthy state.

July 7, 2026 · 13:33 UTC
Investigating

We are investigating an increase in write latency to Cloud Save.
We are upscaling services to reduce latency.

July 7, 2026 · 12:26 UTC

← Back