Multiplayer service failures

Minor incident LiveOps Leaderboards Multiplayer Distributed Authority Lobby Friends
2026-08-24 22:52 UTC · 11 hours, 40 minutes

Updates

Resolved

The service has been fully restored and is operating normally.

August 25, 2026 · 08:00 UTC
Investigating

We identified an issue impacting multiple services. Our engineering team is actively investigating.

August 24, 2026 · 22:56 UTC

← Back