Build Automation – Degraded Windows Performance (Americas Region)

Major incident Collaboration / Unity DevOps Unity Build Automation Queue Performance - Windows Builders
2026-09-09 16:25 UTC · 17 hours, 29 minutes

Updates

Investigating

We are continuing to investigate the degraded performance for Windows 11 24H2 builders in the Americas region. Due to the extended timeframe and regional impact, we recommend switching builds to the European region where possible and permitted by your data requirements (Dashboard > Build Automation > Settings > Location) until the issue is resolved.

September 9, 2026 · 17:50 UTC
Issue

We are currently experiencing degraded performance affecting UBA Windows builds in the Americas region (specifically Windows 11 24H2 builders). Our team is actively investigating and working to restore service.

September 9, 2026 · 16:25 UTC

← Back