DevOps: Degraded performance in US and EU nodes

Minor incident Collaboration / Unity DevOps Unity Version Control Europe node North America node
2026-09-14 17:00 UTC · 1 hour, 39 minutes

Updates

Resolved

Performance has been restored in the affected nodes.

September 14, 2026 · 18:38 UTC
Investigating

The North America and Europe Unity Version Control nodes are suffering from degraded performance. You may see slow access or transient errors while accessing repository data.

September 14, 2026 · 17:48 UTC

← Back